Diaspora Muda Aceh

Kolaborasi Untuk Aceh

Technology Requirement

To participate in DMA courses, please make sure your computer meets the following minimum requirements. Certain programs and tools may have additional requirements. Please view the respective overview page for those details.

Browser

  • An up-to-date version of Chrome is strongly recommended.
  • We also support the latest versions of Firefox, Safari, Opera and Microsoft Edge.
  • At this time, mobile browsers are not supported

Internet Connectivity

  • Download: 2+ Mbps recommended; minimum 1 Mbps.
  • Upload: 0.5 Mbps.

Operating System

  • PC: Windows XP or higher with latest updates installed (note: Internet Explorer 8 is not supported).
  • Mac: OS X 10.6 or higher with latest updates installed.
  • Linux: Any recent distribution that has the supported browsers installed.

Mobile Apps

  • iOS: Requires iOS 8.1 or later
  • Android: Requires Android 4.1 (Jelly Bean) or later

YouTube

  • Ability to watch YouTube videos is required. If YouTube is blocked on your network, please contact your IT support or internet provider.
  • If you do not use the HTML5 player, or are using Internet Explorer, you will need Adobe Flash Player v11 or above.
  • You can find YouTube’s system requirements here.